Patches

P1354 - Errors when performing queries against PostgreSQL databases

Sep 19, 2012
Patch for Monitoring Studio KM for PATROL - Version(s) 8.6.50,8.6.51,8.6.52,8.6.53

Download File

Patch content

Zip file for Monitoring Studio KM for PATROL

Should you install this patch?

Apply this patch if you are performing queries against PostgreSQL databases and errors related to updateable cursors are returned.

What does it fix?

This patch fixes PostgreSQL updateable cursors errors by using a forward-only cursor instead of a static cursor and uses the default locking method instead of optimistic locking.

How to install the patch?

Unzip SW_ODBC_query.zip to the %PATROL_HOME%/bin directory on the managed server. The PATROL Agent does not need to be restarted for the patch to take effect, and nothing needs to be installed on Console systems.